30 Excel függvény, amit mindenkinek tudni érdemes

Többszáz Excel függvény közül összegyűjtöttem azt a 30 darabot, amiről mindenképpen érdemes tudnod. A mélyebb megismeréshez persze alaposabb magyarázat és sok-sok gyakorlás szükséges.

Minden Excel függvény mögött feltüntettem az angol nevet is. Ha más nyelven keresed a függvényeket, akkor itt találsz egy jó függvénynév-fordítót.

A 30 legfontosabb Excel függvény felsorolása

Alap függvények: SZUM (SUM), ÁTLAG (AVERAGE), MIN (MIN) MAX (MAX), DARAB (COUNT), DARAB2 (COUNTA), DARABÜRES (COUNTBLANK)

Logikai és kereső Excel függvények: HA (IF), ÉS (AND), VAGY (OR), FKERES (VLOOKUP)

Összesítő és kerekítő Excel függvények: SZUMHA (SUMIF), SZUMHATÖBB (SUMIFS), DARABTELI (COUNTIF), DARABHATÖBB (COUNTIFS), KEREKÍTÉS (ROUND), KEREK.FEL (ROUNDUP), KEREK.LE (ROUNDDOWN), PADLÓ (FLOOR), PLAFON (CEILING)

Szöveges és dátum Excel függvények: ÖSSZEFŰZ (CONCATENATE), BAL (LEFT), KÖZÉP (MID), JOBB (RIGHT), AZONOS (EXACT), DÁTUM (DATE), ÉV (YEAR), HÓNAP (MONTH), NAP (DAY), MA (TODAY)

Többszáz Excel függvény közül összegyűjtöttem azt a 30 darabot, amiről érdemes tudnod.

Alap Excel függvények

Az alap összesítések, statisztikák. Tegyük fel, hogy vállalkozó vagy, és vannak ügyfeleid, mi érdekel: hány ügyfél van, mennyi bevételt hoztak, átlagosan egy ügyfél mennyit költött (kosárérték), és milyen értékek között mozognak a vásárlások.

De ugyanezek a statisztikák érdekesek egy osztály esetén is: hány tanuló van, mi az átlagos tanulmányi eredmény, például a vizsgán elért pontszámok (az összeg itt kevésbé érdekes), és milyen értékek között mozognak a pontok.

1. SZUM (SUM)

A Szum (a menün AutoSzum szerepel) függvény összesíti a kijelölt tartományon belüli értékeket – jellemzően sorokat vagy oszlopokat. Akár egymástól távoli cellák is kijelölhetőek a Ctrl segítségével (a képletben pontosvessző jelöli). Példák:

=SZUM(A2:A25)
=SZUM(A5:D80)
=SZUM(A:A)
=SZUM(A2:A25;E2:E25)

2. ÁTLAG (AVERAGE)

Az ÁTLAG függvény nagyon hasonló SZUM függvényhez, viszont a végösszeg helyett az egyes elemek átlagát számolja ki. Az üres cellákat és szövegeket figyelmen kívül hagyja. Ha átlagot számolsz, gondold át, hogy nullát írsz a cellába, vagy üresen hagyod.

Példák:

=ÁTLAG(A2:A25)
=ÁTLAG(A5:D80)
=ÁTLAG(A:A)
=ÁTLAG(A2:A25;E2:E25)

Az ÁTLAG függvény használatáról nézd meg ezt a videómat.

3. MIN (MIN), 4. MAX (MAX)

A Minumum, Maximum függvény is nagyon hasonló a SZUM, ÁTLAG függvényekhez. Megmondja, hogy a bemeneti értékek közül melyik a legalacsonyabb, illetve a legmagasabb szám. Itt is megadhatsz cellákat, oszlopot, akár többet is és egymástól távolabb lévőt is. Pl:

=MIN(A2:D15)
=MAX(A2:A25;E2:E25)

5. DARAB (COUNT), 6. DARAB2 (COUNTA), 7. DARABÜRES (COUNTBLANK)

A három DARAB függvény hasonlóan működik: a függvény beírása után jelöld ki a megszámolni kívánt cellákat.

  • A DARAB függvény csak a számokat számolja meg.
  • Ha a szövegeket is (azaz a nem üres cellákat) szeretnéd megszámolni, használd a DARAB2 függvényt.
  • Ha csak az üres cellákat szeretnéd megszámolni, akkor használd a DARABÜRES függvényt.

Például megtudhatod, hány tranzakció / ügyfél / jelentkező stb. van a listádban, vagy hányan válaszoltak / nem válaszoltak egy adott kérdésre.
=DARAB(A:A)
=DARAB2(A2:A25;E2:E25)
=DARABÜRES(A2:A25)

A 14-15-ös pontban 2 további, feltételes darab függvényt is megismerhetsz. A DARAB függvényekről még itt írtam.

Logikai és kereső Excel függvények

8. HA (IF)

Megvizsgál egy összehasonlítást, és ettől függően írja ki az eredményt. Például jelzi, ha nagyobb terület szükséges, mint amennyi megvan. Vagy a laptop vásárlóknak jár 20% kedvezmény

= HA (A2 > B2; “További terület”;”Terület rendben”)
= HA (D2=”laptop”; E2*0,8;E2)

A HA függvény használatáról ide a linkre kattintva találsz egy részletes összefoglalót és videós magyarázatot.

Az informatika érettségi kapcsán is írtam a HA és a DARABTELI (14.) függvényről.

9. ÉS (AND), 10. VAGY (OR)

Gyakran halmozni kell a feltételeket, ilyenkor meg kell mondani, hogy mi a közöttük lévő kapcsolat.

Ha például a B oszlopban szerepel az életkor, és a D oszlopban a férfi/nő adat, akkor az 50 év feletti nők:

=ÉS(B2>50;D2=”nő”)

Ha azokat az ügyfeleket keresed, akik legalább 5x vásároltak (C oszlop), vagy minimum 100.000 Ft értékben (E oszlop), akkor:

=VAGY(C2>=5;E2>=100000)

Önmagában IGAZ/HAMIS eredményt ad ki. (A logikai műveletekről bővebben itt olvashatsz.) Ha ezt szertnéd másra “lecserélni”, akkor építs köré egy HA függvényt, pl:

=HA(VAGY(C2>=5;E2>=100000);”VIP”;”átlag”)

11. FKERES (VLOOKUP)

Az FKERES már egy bonyolultabb függvény, érdemes alaposabban megismerni. A lényege, hogy egy listából kikeres egy konkrét adatot, például adott készülékhez kikeresi a fogyasztását, vagy egy ajtó típushoz a pontos méretet.

= FKERES (E2; A:B; 2; 0)

További segédanyagok az FKERES függvényhez:

Az Excel Tankönyvben 104 függvényt gyűjtöttem össze, ha szeretnél többet tudni az Excelről és a függvényekről, szeretnéd, ha kéznél lenne egy praktikus (formátumú és tartalmú) könyv, akkor rendeld meg.

Összesítő és kerekítő Excel függvények

12. SZUMHA (SUMIF), 13. SZUMHATÖBB (SUMIFS)

Ugyanúgy összesít, mint a SZUM függvény, de csak akkor, ha az értékek megfelelnek bizonyos feltételeknek – például a 0-nál nagyobb, vagy a 100 és 200 közé eső számokat összesíti.

Több feltétel esetén a SZUMHATÖBB függvényt használd.

= SZUMHA (A1: A7; “> 0”)
= SZUMHATÖBB (A1: A7; A1: A7; “> 100”; A1: A7; “<200”)

Ugyanígy meg tudod mondani, hogy mennyit költöttek nálad a női vagy a férfi vásárlóid – feltételezve, hogy olyan oszlopod, amiben szerepel a férfi/nő adat. Vagy kiszámíthatod, hogy mennyit költöttek a női vásárlóid egy-egy konkrét termékre.

14. DARABTELI (COUNTIF), 15. DARABHATÖBB (COUNTIFS)

Azokat a tételeket számolja meg, amelyek megfelelnek a kritériumnak. (Több feltétel esetén a DARABHATÖBB függvényt válaszd.)

Például hány 20 évnél fiatalabb ügyfeled van, és hány 20-30 év közötti, ha az A oszlopban szerepel az életkor?

= DARABTELI (A2: A80; “< 20”)
= DARABHATÖBB (A2: A80; “>= 20”; A2: A80; “<= 30”)

Hány nő van az ügyfeleid között? Ha például a D oszlopban szerepel a férfi/nő adat, akkor:

=DARABTELI(D:D;”nő”)

Ha csak a 20 év alatti nőket keresed?

= DARABHATÖBB (A2: A80; “< 20″; D2:D80;”nő”)

Ugyanígy megszámolhatod a negatív számokat (például banki tranzakciókat).

16. KEREKÍTÉS (ROUND), 17. KEREK.FEL (ROUNDUP), 18. KEREK.LE (ROUNDDOWN)

Megadott számú számjegyre kerekít egy számot a matematika szabályai alapján. Létezik csak felfelé és csak lefelé kerekítő változata is. (Emlékszel ugye, azokra a matekpéldákra, mikor az volt a kérdés, hogy hány X literes hordóban fér el az Y liter bor. Olyankor például felfelé kell kerekíteni az Y/X litert, különben nem lesz helye a “maradéknak”.)

= KEREKÍTÉS (7,86; 1) eredménye 7,9
= KEREK.FEL (7,23; 0) eredménye 8
= KEREK.LE (8,87; 1) eredménye 8,8

Míg a számformátum csak virtuálisan kerekít, addig a függvényekkel ténylegesen levágod a “felesleges” számjegyeket.

19. PADLÓ (FLOOR) és 20. PLAFON (CEILING)

A megadott számot egy másik szám többszörösére kerekíti, a választott függvény szerint le vagy fel.

= PADLÓ (87; 10) eredménye 80
= PLAFON (107,6; 0,25) eredménye 107,75

Az Excel Tankönyvben 104 függvényt gyűjtöttem össze, ha szeretnél többet tudni az Excelről és a függvényekről, szeretnéd, ha kéznél lenne egy praktikus (formátumú és tartalmú) könyv, akkor rendeld meg.

Szöveges és dátum Excel függvények

A szöveges és dátum függvények az Excel legegyszerűbb és legkönnyebben megtalálható, megtanulható függvényei, mivel gyakran egy-egy az egyben a “probléma” nevét viselik.

A szöveges függvények “hozzáállása”, hogy a beírt tartalomról karakterekben “gondolkodik”:

21. ÖSSZEFŰZ (CONCATENATE)

Használd a ÖSSZEFŰZ függvényt, hogy két cellában lévő szöveget egymás mellé írj. Akár saját szövegeket is beilleszthetsz az elemek közé.

= ÖSSZEFŰZ (B1; “–”; A1)

A szövegösszefűzésről korábban már írtam egy külön cikket.

22. BAL (LEFT), 23. KÖZÉP (MID), 24. JOBB (RIGHT)

A cellában szereplő szövegeket karakterekre bonthatod, és tetszés szerint vehetsz ki az elejéről, közepéről és a végéről karaktereket. Pl. ha adott A2 cellában XTNK6632-120 cikkszám (lásd fenti kép):

Az első 3 karakter, XTN: =BAL(A2;3)
4-6. karakter, K66: =KÖZÉP(A2;4;3)
Utolsó 6 karakter, 32-120: =JOBB(A2;6)

Az utolsó számjegy mindhárom esetben azt adja meg, hogy hány karaktert eredményez a függvény.

25. AZONOS (EXACT)

Az Excel alapvetően nem tesz különbséget a kis- és nagybetű között. Pl. a szűrésnél, keresésnél, és az összehasonlításnál sem (pl. =A2=B2 vagy =D2=”Pécs”) A keresésnél kicsit eldugva van lehetőség beállítani, hogy tegyen különbséget.

Az AZONOS függvény azonban figyelembe veszi a kis- nagybetű különbséget, és csak akkor lesz IGAZ az eredménye, ha pontosan megegyezik minden karakter: =AZONOS(B2;C2)

26. DÁTUM (DATE), 27. ÉV (YEAR), 28. HÓNAP (MONTH), 29. NAP (DAY)

A dátumok sok problémát okoznak, mivel igaziból számok, és például 2019.05.15-e volt 43.600! “Normális” (matematikai) módon nem tudod átváltani egyiket a másikra. Viszont az Excel tudja, és a DÁTUM függvény össze tud tenni 3 számból – külön adod meg az évet, hónapot, napot – egy évszámot:

=DÁTUM(2019;5;15)

Vagy fordítva, egy dátumot (43600) szét tud bontani év-hónap-nap elemekre:

=ÉV(B2) vagy =HÓNAP(B2) vagy =NAP(B2)

Sok ügyviteli rendszer szöveges formátumba exportálja a dátumokat. Azt a Villámkitöltés vagy – mivel karakterek – a szöveges függvények (BAL, KÖZÉP) segítségével lehet feldarabolni, és utána a DÁTUM függvénnyel visszaalakítani dátum függvénnyé. Például ha az M oszlopban szerepel a dátum:

=DÁTUM(BAL(M2;4);KÖZÉP(M2;6;2);KÖZÉP(M2;9;2))

30. MA (TODAY)

Mindig a mai nap értékét írja ki (a rendszeridő alapján), azaz minden nap változik az értéke. Segítségével számolhatod, hogy egy bizonyos naptól – pl. születésnap, fizetési határidő – hány nap telt el, vagy hány nap múlva esedékes. Így naponta frissül az érték. Pl:

=MA()-B2

Hasznos volt a cikk? Add tovább a barátaidnak is!

További Excel függvények

Te mit használsz még gyakran, ami nem maradhat ki a listából? Írd meg egy példával együtt a hozzászólásoknál!

Az Excelben több mint 300 függvény van, így csak gondolatébresztőnek szántam ezt a listát. Ha ezt a párat ismered, akkor már egy új helyzetben sem fogsz megijedni, mert könnyen felismered, és magad is rá tudsz keresni (vagy megkérdezheted a VIP Klubban, és gyorsan segítünk).

Érdemes több feladaton begyakorolni a függvényeket, hogy éles helyzetben ne okozzon gondot, hogy melyiket kell használni. (Ehhez is adunk példákat a VIP Klubban)

Az Excel Tankönyvben 100 függvényt gyűjtöttem össze, ha szeretnél többet tudni az Excelről és a függvényekről, akkor ez egy jó lehetőség.

Sőt, az igazán izgalmas rész akkor jön, amikor a függvényeket megtanulod kombinálni, azaz egymásba ágyazni, így egész bonyolult megoldásokat is kialakíthatsz.

Ha szeretnéd jobban megismerni az Excel és az Excel függvények használatát, akkor jelentkezz itt egyéni Excel tanfolyamra! Ha az alapoktól szeretnéd átnézni az Excel funkciókat és függvényeket, és szeretsz másokkal együtt tanulni, akkor várunk a következő csoportos Excel tanfolyamra

Mennyit ér, ha ismered az Excelt?

7 hasznos Excel trükk, amivel időt nyerhetsz

Excel Titok VIp Klub

Gyorsabb, eredményesebb munkavégzés. Magasabb fizetés és több szabadidő!

Napi szinten használod az Excelt, és szeretnél a problémákon gyorsan átlendülni? Legyél profibb a munkádban és érd el a célod!

Excel Titok olvasás- oktatás, könyv

Könyv áráért Excel könyvtár

Jelenleg a klubban rengeteg azonnal használható gyakorlatias tipp van. Nem kell órákig keresned a megoldást Itt megtalálod, ami kell a munkádhoz.

Excel Titok fejlődés- oktatás, könyv

Folyamatosan fejlődsz míg eléred a célod!

Előléptetés, nagyobb megbecsülés vagy több szabadidő? Ezt fogod elérni, mert ha elakadsz a Klubban kérdezhetsz és tanulhatsz.

Excel Titok közösség - oktatás, könyv

Szakértőktől kérdezhetsz akár minden nap

Szeretnél egy támogató közösség tagja lenni, akik ugyanúgy lelkesednek az Excelért, mint Te?

Hasznos volt? Oszd meg az ismerőseiddel is!

Megosztás itt: facebook
Facebook
Megosztás itt: linkedin
LinkedIn
Megosztás itt: pinterest
Pinterest
Megosztás itt: email
Email
Megosztás itt: tumblr
Tumblr
Megosztás itt: skype
Skype
Megosztás itt: whatsapp
WhatsApp

Mi a véleményed? Van kérdésed?​

1 hozzászólás érkezett: “30 Excel függvény, amit mindenkinek tudni érdemes”

  1. Fórizs I. Tibor

    Nekem a DÁTUMTÓLIG fv. is nagyon bejött, amikor a családtagjaim életkorát, vagy a “mennyi idős lenne” korát akartam megkapni, A fv. két dátum közé eső napok, hónapok vagy évek számát számítja ki.
    Szintaktika: DÁTUMTÓLIG(kezdő_dátum;záró_dátum;egység).
    A harmadik argumentumot angolul kell megadni:
    eltelt évek=”y”,
    eltelt hónapok=”ym”,
    eltelt napok=”md”,
    mert a függvény a Lotus 1-2-3-ból származó munkafüzetek támogatására készült.

Írj üzenetet!

Az e-mail-címet nem tesszük közzé.

Excel Titok VIp Klub

Gyorsabb, eredményesebb munkavégzés. Magasabb fizetés és több szabadidő!

Napi szinten használod az Excelt, és szeretnél a problémákon gyorsan átlendülni? Legyél profibb a munkádban és érd el a célod!

Excel Titok fejlődés- oktatás, könyv

Folyamatosan fejlődsz míg eléred a célod!

Excel Titok olvasás- oktatás, könyv

Könyv áráért Excel könyvtár

Excel Titok közösség - oktatás, könyv

Szakértőktől kérdezhetsz akár minden nap

Rólunk mondtátok:
Akartam egy gyors, hatékony tanfolyamot

Neten találtam az exceltitok.hu-t. Akartam egy gyors, hatékony tanfolyamot, és ez annak tűnt. (Az is volt.)

Tetszett, hogy gyorsan tudtunk haladni, és hogy gyakorlatorientált, életszerű anyaggal dolgoztunk. Hogy alkalmazkodtál az egyéni igényekhez.

Enikő

Oszd meg az ismerőseiddel is!

Megosztás itt: facebook
Facebook
Megosztás itt: linkedin
LinkedIn
Megosztás itt: skype
Skype
Megosztás itt: whatsapp
WhatsApp
Megosztás itt: email
Email

Legutóbbi bejegyzések

Kövess minket Facebookon!

Ezt olvastad már?

Tudj meg többet az Excel diagram készítés módjáról

Dobd fel a táblázataidat szép diagramokkal! Az Excel diagram készítés lehetőségeiről már több cikket is írtam és videót is készítettem, nézd végig, és mélyülj el a …

Tovább olvasom →

Kimutatás készítés COVID adatokkal

Ha ismered az Excel kimutatás készítés vagy más néven pivot tábla funkcióját, akkor könnyedén tudod elemezni, összesíteni az adataidat. Most erre fogok példákat mutatni. Alapul …

Tovább olvasom →

Excel feladatok és megoldások

Sokan érdeklődtök Excel feladatok és megoldások iránt, ezért ebben a posztban összegyűjtöm a korábban közzéadott feladtokat, hogy ne kelljen keresgélni. Nagyon örülök, hogy gyakoroljátok az Excel …

Tovább olvasom →